Categories
Linux

Updating to Debian Etch broke Amavis-Stats

Updating to Debian Etch broke Amavis-Stats:

Amavis Detection Statistics
Daily Graphs
amavis-stats::error: rrd_graph(): 1
amavis-stats::error: rrd_graph(): 1
Weekly Graphs
amavis-stats::error: rrd_graph(): 1
amavis-stats::error: rrd_graph(): 1
Monthly Graphs
amavis-stats::error: rrd_graph(): 1
amavis-stats::error: rrd_graph(): 1
Yearly Graphs
amavis-stats::error: rrd_graph(): 1
amavis-stats::error: rrd_graph(): 1

I searched Google for a solution but every other post on the subject suggested downgrading rrdtool. This is not an appropriate fix. I debugged the actual amavis-stats script and here is my fix. It involves commenting out some lines in /usr/share/amavis-stats/amavis-stats.php:

Line 650:

// $opts[] = "COMMENT:amavis-stats v$asVersion ";
// $opts[] = "COMMENT:$enddate \\r";

Line 771:

// $opts[] = "COMMENT:amavis-stats v$asVersion ";
// $opts[] = "COMMENT:$enddate" . str_replace(":", "\:", $enddate) . " \\r";

6 replies on “Updating to Debian Etch broke Amavis-Stats”

Thanks for the workaround / Fix. I had the same error on fresh install of Debian Etch.

I, however, did not comment out the two lines

$opts[] = “COMMENT:amavis-stats v$asVersion “;

and added the version number (1.2.15-0.3) in line 60 as it was left out.

hey brother.

its been a very long time, i wonder if you remember me. i was your bro back in the days when we used to hang out with gavin and chris. write back to me and let me know how your doing. i also want to know if your have been in touch with those two. its been about 8 years since ive lived in utah. it would be good to hear from u all
later beau

Leave a Reply to Dietmar Zlabinger Cancel reply

Your email address will not be published. Required fields are marked *